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Sentry-go KnowledgeBase
 
Title   One or more automatic responses timeout when run.
Applies To   Sentry-go Monitor Response Engine

Problem:
 
When an alert is triggered that causes an automatic response to be triggered - the response script, file or application is run but fails with a "timeout" error.
   

Cause:
   
The script, file or application is being run by the monitor's response component but is failing to complete within the expected time. The monitor then terminates it and returns an error.
 
Solution:

When a response is run, the Sentry-go monitor's response component initiates the request and waits for it to complete. During this operation, the calling monitoring component waits - so that the check can be re-run after action has been taken, and therefore other monitoring performed by that component is also delayed. In order to protect itself, the monitor by default only waits for a given time - 2 minutes (120 seconds) as standard. After this time, the command is considered to have failed, is terminated & returns the timeout error.

If this occurs, it is recommended that the following is checked ...
  • Check that the script, file or application runsbearing in mind it may be run under a different user account by Sentry-go
  • Check that the script, file or application closes once it's been run. If not, the monitor has no way of knowing when it's completed and will eventually timeout.
  • Check to see how long the script, file or application takes to complete. If it's close to the maximum timeout value, check to see why it takes so long. If the delay is unavoidable, consider increasing the timeout value as described below.

The default timeout period for a response is 120 seconds or 2 minutes. In most cases, this should be more than adequate. However, the default behaviour can be overridden as follows ...

  • Logon to the server being monitored - i.e. the server running the Sentry-go Plus! monitoring service.
  • Locate the Sentry-go data directory.
     
    This location will vary depending on your installation and version of Windows installed. Typically it will be under
    C:\Program Files\Sentry-go or C:\Program Data\Sentry-go but to locate it, search your hard drive for the file "Sentry-go.CFG".
     
  • The configuration file is split into sections. Locate the "[General]" section, which will look something like this ...
     
    [General]
    LastConfigUpdateTime=October 05, 2008 11:14:03
    RestartCheckInterval=30
    MaxWebServerThreads=50
    MaxStoredMsgs=100
    Home=C:\Program Files\Sentry-go
    DateFormat=1
     
  • Check for an entry called "ActionTimeout" as in ...
     
    ActionTimeout=300
     
  • If there's an entry, change the number to the new number of seconds you wish the monitor to wait.
  • If no such entry exists (by default it won't), add a new line within the "[General]" section, again, providing the new timeout value. For example, to timeout after 5 minutes (or 300 seconds) ...
     
    ActionTimeout=300
     
  • Save & close the configuration file.
  • The new timeout value will be picked up automatically.

Always bear in mind that longer timeout periods will potentially delay the monitoring process.